banner

¡Alerta! Descubiertas dos vulnerabilidades zero-day en Adobe Flash Player

El mundo de seguridad en las aplicaciones de escritorio sigue "revuelto" sobre todo para las aplicaciones con nombre propio, como es Adobe. Desde que empezarán a salir vulnerabilidades en su lector de PDF (Adobe Reader) en el año que ya ni recuerdo. Pero desde sus versiones más tempranas 6.x, en adelante a los chicos de Adobe no paran de salirle "monos", o lo que es lo mismo, no paran de encontrar vulnerabilidades en sus desarrollos.
Según Kaspersky, los productos de Adobe como Reader, Flash Player y Shockwave se encuentran en el Top 10 de vulnerabilidades del primer cuarto del año 2011. [Kaspersky Labs]
En esta ocasión han aparecido dos nuevas vulnerabilidades (CVE-2011-4694) críticas (0-Day) en Adobe Flash Player que permite a un atacante manipular cuidadosamente un archivo flash (SWF) para ejecutar "cualquier" tipo de código en tu equipo a través del navegador web.

Varios Blogs (AdobeBlog, ThreatGeek)  y sitios especializados  (USA-CERT, PCWORLD) se hacen eco de la noticia, en esta ocasión ha sido un investigador ruso "Intevydis" quien ha descubierto sendas vulnerabilidades, proporcionando los correspondientes exploits (pieza de código necesaria para aprovecharse de la vulnerabilidad), incluidos en la popular herramienta para la realización de "test de penetración" Inmunity Canvas!

Desde Imunity Canvas aseguran que han realizado pruebas satisfactorias (con éxito) del "exploit" en Windows 7 Ultimate y Windos XP Pro totalmente actualizados, sobre los navegadores web más populares.

The attack had been tested against fully patched Windows 7 Ultimate and Windows XP Pro systems running Internet Explorer 7 and 8, Google Chrome, and Firefox.[Immunity's Alex McGeorge]
video

Incluso, los chicos de Inmunity Canvas (vídeo) ha publicado un vídeo de demostración, que podéis ver en el párrafo anterior.

Lo cierto es que esta vulnerabilidad 0-Day de Adobe Flash no solo afecta al sistema operativo windows, sino que también hace vulnerable a dichos ataques a los MacOS X, cuyo exploit estará proximamente disponible, según directivos de Inmunity Canvas.

La peligrosidad de las vulnerabilidades tipo 0-Day significa que el fabricante no tiene disponible ningún parche que solucione el problema. Por lo tanto, mientras el fabricante no actualice el software todo los usuarios estaremos completamente desprotegidos.

Por si esto fuera poco, el lector de archivos PDF de Adobe se ve afectado por las vulnerabilidades Flash, debido a un modulo que incluye estos documentos que permiten añadir contenido flash al mismo. Por tanto, se debe de extremar la precausión, a la hora de abrir archivos PDF de fuentes desconocidas o no confiables.
Flash Player vulnerabilities can be exploited by embedding maliciously-crafted Flash content into websites or PDF documents. Adobe Reader and Acrobat are generally affected by Flash Player flaws because they incorporate a Flash playback component.
Se aconseja y recomienda:
  • Mantener actualizado tanto el Sistema Operativo, el Navegador Web, el Antivirus, como por supuesto cualquier actualización relacionada con Adobe.
  • Además, es muy recomendable utilizar el Add-ons "No-Script" para bloquear cualquier script, incluidos los flash, a la hora de navegar por Internet. Permitiendonos habilitar el contenido flash para aquellos sitios que son de confianza.
¿Que sitios son considerados de confianza? Esta sería una gran cuestión a debatir, no creéis. Pero eso sería un buen material para otra ocasión.

Fuente: Infoworld

No hay comentarios :

Publicar un comentario