banner

Preparando Kali (aka BackTrack 6) Linux para usar Metasploit

Hace unos días se lanzo la versión 1.0 de Kali Linux, la nueva distribución de Linux especialmente orientada a  los profesionales de la Seguridad Informática, ya sean Auditores, Pentester o Forenses informáticos.

No voy a entrar en analizar las diferentes herramientas, ya que seguramente encontraréis múltiples artículos en Internet hablando de las bondades, herramientas y/o mejora que trae la nueva versión de la antigua BackTrack 5 RC3.

En este artículo voy a centrarme en poner a punto #Metasploit.

#Requisitos

Disponer de un equipo y/o máquina virtual con Kali Linux ejecutándose. Puedes conseguir una versión virtualizada (vmware) en la página web oficial

Para las pruebas que se han realizado en nuestro laboratorio (ST2Labs) se ha creado la máquina virtual desde cero, instalando el sistema operativo desde la imagen ISO del Sistema.

¿Cómo empezamos? 

La primera vez que se va a utilizar #Metasploit es conveniente iniciar los servicios antes de empezar a jugar con ellos, en Kali se utilizar postgres SQL para dar soporte a la base de datos de metasploit, es por este motivo por lo que se va a empezar iniciando el servicio de base de datos.

En un terminal de consola ejecutamos el siguiente comando:

> service postgresql start

Y a continuación se ejecuta:

> service metasploit start

Starting metasploit on Kali Linux

Una vez iniciados, se ha creado automáticamente la base de datos msf3 y el usuario msf3 que serán los que utilice metasploit por defecto para conectarse con el sistema de base de datos (postgres SQL).

Una vez ha finalizado el proceso anterior se tiene metasploit listo para empezar a funcionar, no hay más que teclear el siguiente comando en un terminal de consola:

> msfconsole

msfconsole on Kali Linux
Interfaz WEB

Si deseas utilizar la interfaz WEB de metasploit, entonces deberás de registrarte en la página web de metasploit y activar tu instalación con el código / licencia que te enviarán a la dirección de email introducida durante el registro.

Metasploit Community WEB GUI


Metasploit Activation WEB GUI.
ARMITAGE

Ahora vamos a ejecutar la interfaz gráfica "Armitage": ¿Qué sucede? No se encuentra instalado por defecto en el Sistema.

Basta con ejecutar en el terminal de consola:

> apt-get install armitage

Listo, una vez finalizado todo el proceso tendremos, completamente preparado #Metasploit para empezar a jugar.

 ¡ Por ultimo, se puede ejecutar msfupdate por si hubiera alguna actualización pendiente!

> msfupdate

Metasploit update

Configurar Metasploit para que se inicie en el arranque del Sistema

Antes de finalizar, conviene configurar metasploit para que inicie el servicio correctamente durante el arranque del Sistema.

update-rc.d postgresql enable
update-rc.d metasploit enable

Un Saludo.

Referencias:
Starting Metasploit Framework on Kali Linux

11 comentarios :

  1. GRacias hermano estoy empezando con esto de auditorias en Kali linux Gracias Gracias

    ResponderEliminar
  2. Hola llevo algo de tiempo mirando tu site, esta interesante y justo ha surgido la consulta sobre kali. Yo he tenido backtrack desde el 3(era medio complicado para mi hacerlo correr pero por algo se empieza) hasta el sr3 y luego he tenido la brillante idea de migrar(no me gustan la VM) y se extraña ciertas cosas y otras no, pero ahora me da ciertos errores y uno en particular que no he podido solucionar.
    e
    Desempaquetando el reemplazo de linux-image-3.7-trunk-686-pae ...
    dpkg-deb (subproceso): no se puede copiar el miembro del archivo de '/var/cache/apt/archives/linux-image-3.7-trunk-686-pae_3.7.2-0+kali8_i386.deb' a la tubería de descompresión: fallo al leer (Error de entrada/salida)
    dpkg-deb (subproceso): descomprimiendo el miembro del archivo: error de lzma: fin de entrada inesperada
    dpkg-deb: error: el subproceso devolvió el código de salida de error 2
    dpkg: error al procesar /var/cache/apt/archives/linux-image-3.7-trunk-686-pae_3.7.2-0+kali8_i386.deb (--unpack):
    no se pudieron copiar los datos extraídos de './lib/modules/3.7-trunk-686-pae/kernel/fs/xfs/xfs.ko' a '/lib/modules/3.7-trunk-686-pae/kernel/fs/xfs/xfs.ko.dpkg-new': fin de fichero o de flujo inesperado
    Examining /etc/kernel/postrm.d .
    run-parts: executing /etc/kernel/postrm.d/initramfs-tools 3.7-trunk-686-pae /boot/vmlinuz-3.7-trunk-686-pae
    run-parts: executing /etc/kernel/postrm.d/zz-update-grub 3.7-trunk-686-pae /boot/vmlinuz-3.7-trunk-686-pae
    Preparando para reemplazar exploitdb 0.5-1kali0 (usando .../exploitdb_0.6-1kali0_all.deb) ...
    Desempaquetando el reemplazo de exploitdb ...
    dpkg-deb (subproceso): no se puede copiar el miembro del archivo de '/var/cache/apt/archives/exploitdb_0.6-1kali0_all.deb' a la tubería de descompresión: fallo al leer (Error de entrada/salida)
    dpkg-deb: error: el subproceso copiado devolvió el código de salida de error 2
    dpkg: error al procesar /var/cache/apt/archives/exploitdb_0.6-1kali0_all.deb (--unpack):
    no se pudieron copiar los datos extraídos de './usr/share/exploitdb/platforms/php/webapps/3468.txt' a '/usr/share/exploitdb/platforms/php/webapps/3468.txt.dpkg-new': fin de fichero o de flujo inesperado
    Se encontraron errores al procesar:
    /var/cache/apt/archives/linux-image-3.7-trunk-686-pae_3.7.2-0+kali8_i386.deb
    /var/cache/apt/archives/exploitdb_0.6-1kali0_all.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    He intentado lo clasico, ya sea el autoremove, el forzar la desinstalación del paquete e instalarlo de nuevo pero no he dado con la tecla.
    He intentado el forum de kali pero es imposible registrarse por culpa de su capchat.
    A ver si me puedes dar una mano un saludo

    ResponderEliminar
  3. Hola, Ya voy

    KaliLinux esta basada en Debian Wheezy y no en Ubuntu como la BT5, aunque guardan una similitud el sistema operativo es diferente, por lo que intentar migrar (upgrade) BT5RC3 a Kalilinux no es tarea sencilla.

    En este post: tienes algo de información al respecto.
    http://www.pax-pentest.net/penetration-testing/upgrading-from-backtrack-5-to-kali-linux-1-0/

    También aunque no soluciona tu problema: http://forums.kali.org/showthread.php?7818-Upgrading-from-backtrack-to-kali-(dual-boot)

    Creo que el problema puede ser la rutas de instalación en el sistema al ser un paquete para debian y no para ubuntu, por lo te recomendaría analizar las rutas de instalación del paquete, ver el Logs del sistema e intentar averiguar que falla.

    Siempre te quedará instalar KaliLinux directamente en el disco duro.

    Un Saludo.

    ResponderEliminar
  4. Impresionante herramiena, y un minitutorial muy bueno, me has respondido muchas preguntas que llevaba tiempo haciendome y junto con esto http://www.zuh.es/seguridad/metasploit/86/ gracias a esto conozco bastante bien esta herramienta. Un saludo y muchas gracias por tomarte tu tiempo para hacer estos mini tutoriales.

    ResponderEliminar
  5. root@zf19:~# msfconsole
    Could not find rake-10.1.0 in any of the sources
    Run `bundle install` to install missing gems.

    ayuda porfavor.

    ResponderEliminar
  6. Saludos.

    Mi pregunta puntual es: Partiendo de que estámos trabajando con Debian y encima de esta la suite de Kali, puedo usar entornos de escritorios diferentes a Gnome y KDE a LXDE por ejemplo o un gestor de ventanas, ya que creo que esa es una falencia enorme de esta distro, me parece que debe correr sobre un entorno más liviano y no tan robusto como los mencionados.

    ResponderEliminar
  7. root@Ma1nstr3am:~# update-rc.d postgresql enable
    update-rc.d: using dependency based boot sequencing

    root@Ma1nstr3am:~# update-rc.d metasploit enable
    update-rc.d: using dependency based boot sequencing
    root@Ma1nstr3am:~# a que se debe esto ??? gracias

    ResponderEliminar
  8. Hola. He instalado Kali y no me reconoce mi tarjeta wifi. Q puedo hacer? Como hacer para que la reconozca?
    Gracias

    ResponderEliminar
    Respuestas
    1. lo mas seguro amigo no es compatible en modo monitor, una solucion es comprarse una antena wifi compatible. Yo uso una Netsys 9000WN para los pc que no me reconocen la targeta de red bajo backtrack,kali,xiaopan,etc.etc....

      Eliminar
  9. Gracias por compartir tus conocimientos, de gran ayuda. Justo vengo de instalar kali en un macbook pro en dual boot con mavericks osx y tu tuto me vino como anillo al dedo.
    s4lu2

    ResponderEliminar
  10. Hola, Buen día.
    Oye yo instale kali, y lo use por un tiempo sin problemas, un día no abrió la terminal y ahora ya no puedo hacer nada por que la terminal esta como deshabilitada o algo así. Sabes como remediarlo?.
    Gracias

    ResponderEliminar